Nissan 370Z Tech Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
My friend has a Fuji. y-pipe on his 350z that he had no longer than 2weeks and i jack the car up and take it off cause we found out it was broke. The **** is in two we pull the y-pipe out and at the end were both pipes would meet into one is still bolted on and the rest of it on the ground. He is mad most likely try to get his money back and pick one up from my buddy Toykilla i don't know what to say but ill have pics up tonight. Hope this made some sense the pics will show more.
 

·
Premium Member
Joined
·
35,304 Posts
Wow, I hope it's an isolated case. If it is, I'm thinking that the retailer will practice good business by replacing it for free and find out what the problem was with the broken one.
 

·
Registered
Joined
·
16,332 Posts
any idea what might have caused it? run over something? maybe the fitment wasnt good so ther was some inherent stress in the pipe.. what exhaust is he running?
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
He's running stock exhaust, and this car doesn't get driven at all it has never been bottomed out at all either. I have no idea but a quailty product shouldn't just break by the weld might just be a bad weld which sucks. Pics soon guys once i get home from work, you will see what im talking about it's not pretty.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #5
Toykilla i took this off the site hope u don't mind till i get real pics, But yeah were the red cricled part thats what was still on the car and the rest was on the ground and let me tell ya it was a bitch to get off cause of the pipe moving when u tired to unbolt the bolts off but we did get it off though.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #7
I know **** sucks, i might have to meet you so you can show him the ones your selling cause he said he doesn't want that brand anymore. Plus i need to talk to you about my mold for my boost controller im ready to do it.
 

·
Registered
Joined
·
55 Posts
Originally posted by Z1 Performance@Oct 26 2004, 05:27 PM
was it genuine Fujitsubo or replica?

that is what i was wondering. i know they were selling a replica for about $350 or something?
 

·
Registered
Joined
·
16 Posts
It probably is just a bad weld and also an isolated case. Eventhough it might be isolated, when it happens to you who cares if it never happened before.
 
1 - 10 of 10 Posts
Top