Nissan 370Z Tech Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
53261


So I am having an issue with the whole right side of the turn signal not wanting to turn off when the engine is off. They do not flash, I checked the IPDM but not exactly sure as to which fuses or relay has gone bad. This happened when I washed the vehicle at one of those drive in bays. I noticed water was entering into the firewall grommet, so I fixed that problem. But the lights stay on. This morning, the battery died and I had to get a replacement. I would disconnect the negative terminal multiple times and still they shine. As of now, the battery is disconnected due to drainage. Not sure if it's the bulb cause the whole right side lights up.

If anyone knows the answer to my problem, some feedback would be appreciated. I've spent way too much on maintenance alone and I do not want to take it to the shop again. If it's an issue I could work on my own, I'd much rather do that. Thanks.
 

·
Super Moderator
Joined
·
1,612 Posts
Since I don't own a Z34, I can't answer this question. But I'd suggest looking through the factory service manual (FSM) to find a schematic of the fuses and relays for the lights. Don't have a 370Z FSM? Try using this link:

Nissan Service Manuals - NICOclub

Good luck and be sure to post what the fix turns out to be!
 

·
Registered
Joined
·
1 Posts
The problem could be inside, maybe during the washing water got into the chip, which doesn't work. I had such a problem, and I understood that I had to change the lamps entirely to work usually. I was thinking of buying from the internet, and I found a pretty good offer. The decision was to blame that seller, but friends recommended me first to check the product in case of something and for that to use MOT Check & MOT History - Car.co.uk . Unfortunately, I found out that that product was fake and didn't work entirely as it should. So I decided that it would be better to buy from specialized stores.
 
1 - 3 of 3 Posts
Top