Nissan 370Z Tech Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
The vehicle idles bad but when the fan for the a/c and heat is on it idles solid, but when it gets warm and the fan isnt on it idles bad then dies and wont start back up until it cools down. No codes are being thrown
 

·
Registered
Joined
·
1,162 Posts
The last time I responded to one of your queries, there was no response. Can you provide some basic information on your Z? Like how many miles are on the odo? Any mods or significant repairs that can affect the idle? I'm willing to help, but wild guesses are not very helpful...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Sorry, i was still figuring out this website wasnt sure how to reply, theres 150k miles on it. Theres a raised intake mod and cold air intake but that was on the car before i bought it a couple years ago. I havent done anything that should effect the idle so thats why im unsure of the source of the problem
 

·
Registered
Joined
·
1,162 Posts
Have you recently done a scan of the ECM to determine if any codes are held in memory? At 150K, it could be any number of things, but I suspect there's a code or two that could help narrow it down.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Well my reader wouldnt connect at all when it was throwing codes so i took it to Nissan to let them scan it and i changed everything that was a redflag (cam and crank senors and new bettery) but it hasnt thrown anymore codes since those changes which confuses me. Because before i changed them it had the same symptoms except now its dying and not starting back up until it cools off but no check engine light or anything. It runs great except at idle but with the fan to the a/c and heat on it idles solid.
 
1 - 5 of 5 Posts
Top