Nissan 370Z Tech Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
276 Posts
Discussion Starter · #1 ·
Weird Rubbing sound from left front side of car!

--------------------------------------------------------------------------------

As of today in the evening I have developed a weird Humming/Rubbing sound from around the left side of the engine bay or the left front wheel area. It sounds the same as if the Sturt bar was rubbing against the hood at low speeds and also when for example coming into a driveway where there is a dip and then the driveway goes up. In this case however you hear more than rubbing you hear like something stretchign and popping. At idle the noise is not there. On the FWY for example i hear it a little but you have to really listen to look for it.

To listen I have to go to my back alley and drive the car slow and you hear like marble rocks rolling from left to right under the engine bay or passenger seat area.

Im concerned as I may be confusing this with engine knocking or cracked block but again im mechanically impaired. I have Tein S-techs, 20 rims, High flows, sway bars, true duial exhaust and nitorus. I have many more mods but I think this mentioned are the ones that in any case could be a cause. Im just concerned the engine is going. However the car runs like crazy it is in perfect condition never been better.

Im so concerned. I can have it be whatever but not the engine.
 

·
Registered
Joined
·
598 Posts
try removing the strut bar and see if there is any difference. might not hurt to jack her up and just take a good look around for anything unusual. i had a similar issue once , long story short, there was about a two inch sectin of a tree branch stuck somewher near the rear tire it was amking some wierd noises.

lastly, i t may be one of your springs that may not have been positioned properly causing it to shift under certain conditions causing your popping sound.
mdzowner
 

·
Registered
Joined
·
276 Posts
Discussion Starter · #3 ·
Originally posted by mdzowner@Jul 30 2005, 05:36 AM
try removing the strut bar and see if there is any difference. might not hurt to jack her up and just take a good look around for anything unusual. i had a similar issue once , long story short, there was about a two inch sectin of a tree branch stuck somewher near the rear tire it was amking some wierd noises.

lastly, i t may be one of your springs that may not have been positioned properly causing it to shift under certain conditions causing your popping sound.
mdzowner
[snapback]139503[/snapback]​


I removed he strutbar but the noise is still there. I didnt jack her up since I dont have the equipment but I did take look underneath but there is nothing hangin. This is worrying me.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top