Nissan 370Z Tech Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
So starting last night my speedometer stopped working in my 2005 350z. It seems to be fine till about an hour of driving or so, and then it will drop down to 0 and/or bounce between 0 and my current speed. Same thing with the digital speedometer as well. The odometer seems to be working fine, but I'm not 100% sure.

Anyone have any idea what may have caused this issue? I have had the car for a little over a year and have never had this issue before.

I was reading it could potentially be an issue related to my head unit? I have an aftermarket Pioneer head unit, that was installed before I bought the car.

I have always had issues with the right side speakers cutting in an out when I hit bumps and seemingly more frequently in the rain. Or sometimes when I hit a bump my ipod will get disconnected (without physically being unplugged from the head unit) I have an ipod connector coming directly from the head unit.

I am leaning towards there being a grounding issue from behind the head unit itself, (causing the speaker issue I've always had, and now the speedometer not working) but I am not sure, nor do I really know where to start.

Any help would be greatly appreciated!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
So I just wanted to reply in case anyone ever has this issue and comes across this thread.

I seem to have fixed the issue (knock on wood). I disconnected the battery, and I took the main headunit/dash area off and got behind the headunit. I reseated all the connectors I could find, and actually found a few wires that were exposed/poorly insulated so I went ahead and wrapped some electrical tape around them, making sure they wouldn't be touching any metal and shorting out, and double checked where the unit was grounded (that seemed to be the most solid part).

I put everything back together, and everything seems to be working great now. My speakers/speedometer aren't cutting out anymore when I hit bumps, even really rough ones.

Not sure what fixed it, many variables, but just wanted to share my success.
 
1 - 2 of 2 Posts
Top