Nissan 370Z Tech Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2003 Track Model, only 5,000 miles. The engine seems to idle very rough when at stop lights, etc. The oil pressure also seems to be low when this rough idling occurs. The dealer said that this was normal, but all other Z's I have been in have not had such a problem...

Any ideas or solutions???


Thanks!
 

·
Registered
Joined
·
6,259 Posts
well my idle is not all that smooth either!! try installing a grounding kit and see if it smooths out your idle
 

·
Premium Member
Joined
·
5,138 Posts
check your air filter. might have some leaves sucked up into the airbox
 

·
Registered
Joined
·
5,408 Posts
Do you have an intake or anything on it? I had an AEM on mine and it used to be bad, but switched to a popcharger and it got much better.
 

·
Registered
Joined
·
5 Posts
I have a 2004 Z with 10,500 miles.. mine just started idleing rough at 750 RPM's (is that normal?) about 2 months ago, I took it to the dealership and they said nothing is wrong but reset the idle anyway. Its still doing it!! Any ideas? :newbie:
 

·
Registered
Joined
·
1,333 Posts
There is a vacuum hose that is connected to your upper plenum right near the throttle body. I would suggest checking to see if all of your hoses are still connected and that there aren't any leaks/cracks in teh hoses. That could be the problem but it is unlikely unless you added ground wires and happened to loosen up a bolt back there. Anyway, look around to make sure.
 
1 - 7 of 7 Posts
Top