Nissan 370Z Tech Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
3,089 Posts
Discussion Starter #1
hi guys

curious if anyone has had this same problem

that small red alarm led on the top of the dash is always on, regardless of the car being locked, unlocked, on, etc

this happened a couple weeks ago, but it seemed to reset itself, or maybe i did something, to get it back to normal

anyone what im going on about here?
 

·
Registered
Joined
·
1,154 Posts
It is normal Sam... don't worry about that... I think that's just the NATS... (Nissan Anti-Theft System).. that red LED just keeps on flashing itself whenever the engine is not running... Perfectly normal!

cheers,

richie
 

·
Registered
Joined
·
1,176 Posts
Yep - perfectly normal. It signifies an immobilisation system on board, but I reckon that it gives any dumb ass thief the impression that an alarm is fitted to the car.
 

·
Registered
Joined
·
3,089 Posts
Discussion Starter #5
no guys its not flashing at all, its permanently on

well jumping in the car tonite, after being out all night, it seems to have gone back to normal

i think ive sussed it out though. whenever i wash the car and play the stereo for a long time it stays on, prob has something to do with earthing or low battery level
 

·
Registered
Joined
·
121 Posts
i was having problems with the red LED staying on while my keys were in,

problem was my key needed to be recoded...

but my car wasnt starting when that happened, happened probally once every 10 times i tryed to start the car...
got my keys recoded and its been good since
 

·
Registered
Joined
·
3,089 Posts
Discussion Starter #9
^ thats something ill definitely keep in mind dude, thanks :cheers:

could just be me reaching here, but i did find the key hard to get out of the ignition when the light was on
 

·
Registered
Joined
·
121 Posts
the red led flashes all of the time,
when you put your key in and turn to acc
it goes off..

so yeah my problem was when they replaced the ECU, they didnt recode the keys properly,

so the immobilser wasnt reading the keys properly

when i turned to acc the red light would be on..
if i try start the car, it wouldnt start...

took me a while to figure out why my car wasnt starting, **** red lights.

there was a TSB for this too..

even if this isnt happining, if the red led is staying on all the time, it means something is up with the NATS system
best to get checked out
 

·
Registered
Joined
·
2 Posts
i was having problems with the red LED staying on while my keys were in,

problem was my key needed to be recoded...

but my car wasnt starting when that happened, happened probally once every 10 times i tryed to start the car...
got my keys recoded and its been good since
I’m having the same problem right now. My car isn’t starting it just cranks and I noticed the red light isn’t flashing it just stays on. What do you think is the problem?
 

·
Super Moderator
Joined
·
1,277 Posts
This is a common problem for new owners. NATS is not reading the chip in your key and preventing a start. Have you tried using your other key?
 

·
Super Moderator
Joined
·
1,277 Posts
Take your title with you to the dealer and pay them to reprogram your NATS for your original key and cut a backup.
 
1 - 14 of 14 Posts
Top