Nissan 370Z Tech Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,735 Posts
Discussion Starter #1
OK Guys,

Got my pop charger in the mail today (finally!). I've got the how to from this site, but does anyone have any tips or suggestions before I start the install?
 

·
Registered
Joined
·
16,332 Posts
shouldnt be too difficult.. i think the how-to sums it up nicely.. Main thing i have learned :Be careful and do not rush! You will break things if you hurry projects.

Have fun !
 

·
Registered
Joined
·
5,408 Posts
Also dont over tighten the bolts! I have seen many people who had this problem and snapped the head off. Just a heads up.
 

·
Registered
Joined
·
1,728 Posts
I'll say this once more: The install is easy. Only 'problem' for me was starting the two small screwholes for the heat deflector in the plastic intake duct. Finally stopped futzing with the drill & used a piece of hot baling wire.

s
 

·
Registered
Joined
·
1,735 Posts
Discussion Starter #6
Yeah you weren't kidding about those two holes. Tough angle to get at, and you can't really take out the snorkel to line them up very well. I ended up only doing one screw... I think it'll hold the heat shield in place just fine. Thanks everyone for teh quick responses, and special thanks to toykilla for helping me out last night when I had a few questions. You guys rock!
 

·
Registered
Joined
·
378 Posts
I installed mine about 700 miles ago. The sound was GREAT until recently. I've noticed the sucking sound isn't as load and it takes more of a throttle to get it started. I checked for debris in the filter already. Any other ideas?
 

·
Registered
Joined
·
1,735 Posts
Discussion Starter #10
I love it! That supercharger sound is awesome... i only wish I didn't have to be so high in the RPM's to attain it!

Hugo, I'd check to make sure the snorkel and the intake assembly were lined up all straight. If they are, and there's no debris... I don't know?
 

·
Registered
Joined
·
36,128 Posts
Hmmmmmm are they lifetime filters guys? My K&N Typhoon has a lifetime filter that you need to get some kind of cleaning oil for the filter, but aboslutely shouldn't be that much gunk in there Hugo after only 700 miles.....wonder if you should contact JWT directly???

This is taken off the "contact us page" at JWT website:

We are receiving over 60 email questions each day and try as we might, cannot get to every one. Simple yes or no type questions will always get answered before long technical "story questions". If you need a question answered that has a lot of details, it will probably be returned with even more questions from us, back and forth. This type of question is better handled by phone (619 442-0680). If you do not get a response within a few days, try again (note that it is a 2nd try in the subject) or give us a call between 8am and 5pm PST Mon.-Fri. We look forward to serving you in the most effective way possible, Thank You!
 

·
Registered
Joined
·
1,735 Posts
Discussion Starter #12
Yeah I thought about it, but if I remember correctly, you only need to clean and reoil the filter every 5000 miles or so. It should definately be fine after only 700.
 
1 - 12 of 12 Posts
Top