Nissan 370Z Tech Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1 (Edited)
Hey everyone, long time lurker, infrequent poster but I know how much good stuff can come from asking for help on here, so here I am. Here's my dillema(and as much related history I can come up with):

The last time I got my oil changed, everything was going good until I threw a P0340 code. After some investigative work, and replacing my camshaft position sensor in bank 1, I was good to go again. This most recent time I got my oil changed, another check engine light code came on, but it was P0345. So I changed out the OTHER camshaft position sensor. After I reset the code, another one came back on a day or so later, but it turns out it's a P0021. Now this one I'm having some trouble diagnosing since a lot of different forums have a lot of different answers. I'm hoping that by me giving a little info about the history of the SES codes, it may help shed some light. Also, my fuel economy is HORRIBLE... or seems that way. My friend at the Nissan service dealer(more of a text me if you have Nissan questions friend) said that it could be the valve assembly solenoid... which I'm all for replacing(when I find out where it is and the part online) but I wanted to get some more seasoned opinions and see if anyone had a consensus. I do know that my oil levels are fine, if a TEENSY bit high, but nothing out of the ordinary.

Any ideas or suggestions what my next steps should be?
 

·
Registered
Joined
·
652 Posts
It may be that no one currently on this forum has seen that fault code before. Even if they had, given the number of possible causes, diagnosing your particular problem based on someone else's experience is likely to lead nowhere.

For reference on fault codes, download the Service Manual for your particular model year at this link: Service Manuals. Engine faults, their causes and diagnostic procedures are contained in the ec.pdf section.
 

·
Premium Member
Joined
·
5,866 Posts
^^^^^This. I did a quick Google search and quite a few pages came up - give that a try: P0021 Nissan That code seems like it could several different things and at least one person said it did not affect performance so he is living with it. Anyway, take a look.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #5
^^^^^This. I did a quick Google search and quite a few pages came up - give that a try: P0021 Nissan That code seems like it could several different things and at least one person said it did not affect performance so he is living with it. Anyway, take a look.
I did a Google Search too and there were so many results, it was almost inconsistent. The guy that said he just lives with it, that's all well and fine, but my MPG is 11 city, driving the speed limit, soft pedal. The gas consumption really hits when the car is idling... highway is great MPG as long as I stay around 2500 RPM. The reason I asked here is because I was hoping to find some people with actual experience pertinent to my same situation. I can Google.... I can Google just fine, in fact my first three pages of Google results are all purple links now(meaning that they've already been visited).
 

·
Premium Member
Joined
·
5,866 Posts
^^^ yeah, I noticed the same thing. With that crappy of gas mileage, you most certainly have a problem, but as you said, too many options. :dunno:
 

·
Registered
Joined
·
77 Posts
Discussion Starter #7
^^^ yeah, I noticed the same thing. With that crappy of gas mileage, you most certainly have a problem, but as you said, too many options. :dunno:
Well it's not that there are that many people with the same problem.... mine is very specific, and everyone else has thrown different codes, some people have had clutch work then got the code, others have had serious engine issues and that code... I've yet to find someone else who has had the same issue after an oil change, after a P0340.

I DID take the solenoid apart last night and cleared a large piece of debris from the filter, but the SES came back on. It seemed though, that there was little to no oil inside the solenoid, versus the other one(I cleaned for good measure) had a fair amount of oil in it when I took it off.....

ideas?
 
1 - 7 of 7 Posts
Top