Nissan 370Z Tech Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
483 Posts
Discussion Starter #1
My car's idle seems to have a mind of its own. Sometimes it would run up and down and shake hard, sometimes it will just run up and down a little and shake a little less. I had the dealer check it three times already, they basically just run the codes and told me to f&&( off. This is a car I bought new with 12 miles in December, do you guys have a fix for it? I heard ground kit helps out a lot, what kit do you guys recommend? Also how do you adjust the idle on these cars?
 

·
Registered
Joined
·
150 Posts
I experienced the rough idle also, I installed a JDM ground kit and it didn't do dick. But after about 8k miles it got much smoother. The pistons, cylinder walls, or both (can't remember) are coated with molybdenum which takes quite some time to break in. Also that working in conjunction with the piss poor flywheel design accounts for the crappy idle, just give her some time to break in, the VQ is built to last a long time and shee needs a good break in period to smooth out, but trust me the longer she goes the smoother she will get. You can try the grounding kit, but I honestly didn't notice anything except that the ground cables look horrid after 10k miles when the discolorization sets in.
 

·
Registered
Joined
·
191 Posts
[/quote]

So how do you really feel about the grounding kit? :lmfao:

I have the same thing with the idle (about 5500 miles on it), but it seems to be getting better with each and every day, so i stopped worrying about it for now.
 

·
Registered
Joined
·
620 Posts
From what I understand the ULEII ECU in the 2004.5 and up have no idle adjustment, dealer or otherwise.

My car did this from time to time but at not regularly enough to even see a pattern. It really sounded to me like a pattern of misfires that was made the engine stumble. A few times my wife thought it was going to stall.

I have no grounding kit.

Since I have installed my plenum spacer about a month ago it has not happened but I can't say for sure if I have been in the same conditions that cause it. I also don't know why it would have anything to do with it unless it was an on again off again vacuum leak from the plenum I just happened to fix when I moved stuff around.

Chris
 

·
Registered
Joined
·
15 Posts
I read on the APS site that they traced a transient misfire to the crankshaft position sensor cable. A shielded cable comes with their kit. Maybe?
 

·
Registered
Joined
·
483 Posts
Discussion Starter #7
Sounds like a stupid Nissan problem that they will never fix, the dealer told me idle jumping up and down 100-300rpm is normal. What a bunch of $%^&*(

Anyway, how much is that cable? I am willing to pay to get it fixed and then sue Nissan to get all money back for it plus some more.

Thanks for the help guys, now if i can find the fix for the other stupid quirks. I hope this is the problem, also i want to see if the ground is an issue
 

·
Registered
Joined
·
655 Posts
Originally posted by tmak26b@Mar 12 2005, 03:41 AM
Sounds like a stupid Nissan problem that they will never fix, the dealer told me idle jumping up and down 100-300rpm is normal.  What a bunch of $%^&*(

Thanks for the help guys, now if i can find the fix for the other stupid quirks.    I hope this is the problem, also i want to see if the ground is an issue


Wow, 100-300RPM? That's crazy. Mine fluctuates around 500-600RPM and I had Nissan check that out because it seemed a little low at times. They didn't do anything about it though because it's "normal". :nana:

What other quirks are you talking about?
 

·
Registered
Joined
·
483 Posts
Discussion Starter #12
It's just a retarded Nissan problem, I guess I will have to accept the fact that I bought a piece of crap. I should have just bought the S to begin with.
 

·
Registered
Joined
·
483 Posts
Discussion Starter #13
[/quote]


What RPM did you launch at for your 13.9 sec run? I am going to sell my car before the warranty runs out, I am going to get my money's worth on it. What RPM should i launch the car at to get a good itme

thanks
 

·
Registered
Joined
·
483 Posts
Discussion Starter #15
I love my car, but its ridiclously how stupid Nissan engineers are. I really think the car is put together in Korea, not Japan. The quality is not there and some of the things they do on the engineering side is out of wack. I will trade this in for the Cayman when it comes out later this year, my S' quality is 20x better
 

·
Premium Member
Joined
·
35,304 Posts
So when's this going to happen?
 

·
Registered
Joined
·
17 Posts
I have this same rough idle problem, but it I only noticed it after I put in an Injen CAI. Some times the idle drops so low the engine shakes and sounds like its going to stall. The fact I noticed it after I put the CAI made me think I had a leak between the MAF sensor and the throttle body but I can't find one, so I think I am going to put the car back to stock and see what happens.
 
1 - 17 of 17 Posts
Top