Nissan 370Z Tech Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
1,049 Posts
Discussion Starter · #1 ·
First, I must say that after installing Crawford High Flow Cats and APS True Dual 2.5 exhaust, I love it!!! I will post pictures, and go into detail later.....


Drove just fine from the shop home. Drove to around after that a little longer, and punched it at one point in second gear. About 2 minutes of non-stop driving fly by, and as I get into my alley, the car shuts off with the brake light, VDC light, check engine soon light all come on. I had to keep the key turned for a good 6 seconds before she would start back up again. What could be going on?????


Thinking of going to the dealership to have them run diagnostics.

Please Help..... :ahhh:
 

·
Registered
Joined
·
1,049 Posts
Discussion Starter · #3 ·
on the other hand, who is in your avatar?
Josh, I don't know her name, but hopefully, my future wife :biggrin:
 

·
Registered
Joined
·
1,635 Posts
Hey thats my wife
 

·
Registered
Joined
·
16,332 Posts
back on topic.. is your car starting fine now? With my 2003 it went into "limp" mode a few times for no aparant reason.. would not rev past 2k rpms..
 

·
Registered
Joined
·
3,687 Posts
well i suggest trying to reset the ECU...hopefully everything will clear up.

maybe u should have given it some time for the ECU to adjust.

give it a shot and tell us what happens
 

·
Registered
Joined
·
1,049 Posts
Discussion Starter · #8 ·
Josh, sory no links or pics for her. I found that portrait jumbled up with some other girls. Try this link for a bigger picture: http://img491.imageshack.us/img491/4518/ass79qu.jpg


So, I just got back from the dealer, and they said that all checked out fine. The burning smell is normal from the enamel on the cats burning off. No fault codes registered with the computer. Most likely, the O2 sensors are not used to what they are experiencing, and it should just take some time for the ECU to adjust.

She stalled again on the way to the dealership, but started right back up with a quick turn of the key. Also, I was cruising at 35 in 3rd, and the power felt slightly on and off for a bit; same thing happened for an instance on the highway at 60MPH. At one point she idled at 1K RPM, but went back to normal right after.

On the way back, everything ran normal, and felt fine.

P.S. I strongly recommend getting to know your service advisor!! When I pulled up, they were packed. Right away he pulled my car around back, and when I got back there in 10 minutes, they had already checked everything out - AMAZING!!!

BTW, guys, thank you very much for all of quick response, I appreciate it!
 

·
Premium Member
Joined
·
35,304 Posts
Hey thats my wife
Honestly Steve, your wife is way better looking than that. :thumbsup:

As for the topic at hand, I'm assuming that the battery was disconnected before the modding began. I know some ppl might scoff at that, but it's just one of those things that is you never know really helps or not. Anyway, I'm assuming that your ECU is trying to configure itself to the new AF readings it's getting from all the variations you're putting it through with your driving and the mods installed.

With that said, I'm glad you got her fixed and are enjoying the **** out of it. :shiftdrive:
 

·
Premium Member
Joined
·
17,697 Posts
Mine shut down when I was cruising in neutral a few times. This could be normal, but you do have a few mods. After a few days of it happening you might want to try to get into the dyno.
 

·
Registered
Joined
·
1,049 Posts
Discussion Starter · #15 ·
Going to get it in on a dyno a.s.a.p. Drove it tonight, and everything seems fine, with noticeable gains. Can't wait to find out what its putting out.
 

·
Registered
Joined
·
5,437 Posts
Make sure you have about 100 miles or so on it before dyno. By then, the computer will have found the right settings and should be making the best power.
 

·
Premium Member
Joined
·
6,474 Posts
Make sure you have about 100 miles or so on it before dyno. By then, the computer will have found the right settings and should be making the best power.

Go on , please.

There are three timing maps I believe in the ECU. To extract the most power, the rumor was you had to do a few pulls to redline in 2nd gear. And if the ECU was getting inputs in liked (ie no knock) it would switch to the more aggressive map.

God I can't wait to get rid of this ECU. lol
 
1 - 17 of 17 Posts
Top