Nissan 370Z Tech Forums banner

1 - 20 of 40 Posts

·
Registered
Joined
·
5,408 Posts
Discussion Starter #1
Just installed my new stuff this weekend. I got 2 JL Audio 300/2 amps, Infinity Kappa Perfect 6.1 components for the doors, and a JL Audio 10w3 sub which I made a custom under the strut bar box for. The sound is great and so much cleaner than my old setup. Here are some pics.

Also I will be offering my services to make these boxes for anyone interested: http://www.350z-tech.com/forums/index.php?showtopic=4867&hl=









 

·
Premium Member
Joined
·
35,304 Posts
I think it's time to seriously consider upgrading my stock setup.

Nice job, Dave! How long did the sub box take to make?
 

·
Registered
Joined
·
5,408 Posts
Discussion Starter #3
Thanks Dave! Prob intotal about 4-5 hours. Pain in the ass to make the cuts perfect
 

·
Premium Member
Joined
·
35,304 Posts
BTW, what is that in the first pic at the top of your rear window?

I like the clean install look. I miss my old setup in the Z32. It was soooo clean.
 

·
Registered
Joined
·
5,408 Posts
Discussion Starter #6
Thats my Valentine 1 below the rear window
 

·
Registered
Joined
·
5,408 Posts
Discussion Starter #7
Originally posted by Conceyted@Jan 15 2005, 04:46 PM
absolutly love it. Looks awesome bro!

Thanks Chris. Will swing by later to show it to you
 

·
Premium Member
Joined
·
12,469 Posts
Nice work Dave....I've heard aftermarket speakers are a pain to install in our doors. Congrats on the new system...
 

·
Premium Member
Joined
·
17,697 Posts
Looks SWEET Dave!

Very clean for a custom job!

My Stealthbox is soooo clean, even with the stock head unit, I'm sure this setup is perfect. What hu are you running again?
 

·
Registered
Joined
·
5,408 Posts
Discussion Starter #12
Originally posted by Redefined350z@Jan 15 2005, 05:18 PM
Looks SWEET Dave!

Very clean for a custom job!

My Stealthbox is soooo clean, even with the stock head unit, I'm sure this setup is perfect. What hu are you running again?

Thanks Buddy. I have a Alpine 9833 cd player. I just added a pic of it in the original post
 

·
Registered
Joined
·
297 Posts
Nice set up. Like the amp rack.
 

·
Registered
Joined
·
5,408 Posts
Discussion Starter #18
Thanks everyone!

Here are some more pics of the amps per Bluedragons request...



 

·
Registered
Joined
·
87 Posts
Looks good. It was always a general rule of thumb not to mount amps to the sub enclosure for vibration reasons. Solder joints, even when not cold, don't lke severe vibration.
Are they drirectly mounted to the enclosure?

Just a little advice from many years of installing.
 

·
Registered
Joined
·
785 Posts
Originally posted by jreed@Jan 17 2005, 08:41 AM
Looks good.  It was always a general rule of thumb not to mount amps to the sub enclosure for vibration reasons.  Solder joints, even when not cold, don't lke severe vibration.
Are they drirectly mounted to the enclosure? 

Just a little advice from many years of installing.

They are directly mounted to the enclosure... uh ohh :-/
 
1 - 20 of 40 Posts
Top