Nissan 370Z Tech Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Hello all,

I just ordered a new OEM clear plastic cover for my gauge cluster because the previous owner put some sort of cleaner on the original on that trashed it... I was wondering if anyone who has already removed this part from their 350z in the past could help me out with some instructions for the removal?

Any help is greatly appreciated!

Thank you!
 

·
Premium Member
Joined
·
12,469 Posts
I thought he was asking about the smaller three gauge cluster that holds the multi-data display, oil pressure and voltage meter. Well done though boosted24. :thumbsup:
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #5 ·
Thank you 24boosted... this is very helpful! It is in fact the Combination Meter that I am working with... (I am replacing part #2 in the diagram)

I wish I had step by step pictures like you do for the dash removal for this though, because I still have some questions as to how it is properly disassembled.

For example, looking at the diagram that you provided, how is #1 connected to #2? Adhesive?
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #6 ·
Does anyone know the proper method in removing #2 from the diagram of the Combination Meter above? I looked at mine last night again and part #1 does not want to come off easily, (and I don't want to break it).
 

·
Premium Member
Joined
·
4,917 Posts
Is your Z still under warranty? I had a similar problem only with the 3 pods above the nav, and my dealership replaced them all at no charge under warranty.
 

·
Registered
Joined
·
88 Posts
Originally posted by SubEclipse@Aug 25 2005, 02:21 PM
Thank you 24boosted... this is very helpful!  It is in fact the Combination Meter that I am working with... (I am replacing part #2 in the diagram)

I wish I had step by step pictures like you do for the dash removal for this though, because I still have some questions as to how it is properly disassembled.

For example, looking at the diagram that you provided, how is #1 connected to #2?  Adhesive?
[snapback]149407[/snapback]​



No probs, do a write up once you have it taken out so we have the info here to share with others.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #9 ·
Originally posted by Hazade@Aug 26 2005, 10:19 AM
Is your Z still under warranty? I had a similar problem only with the 3 pods above the nav, and my dealership replaced them all at no charge under warranty.
[snapback]149647[/snapback]​


Thanks for the info... I just scheduled an appointment for them to determine if it can be considered a warranty issue or not.

I'll be shocked if it is though, because it's obviously because the last owner of my Z was a moron and used a cleaner on my gauges that shouldn't have been used.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #10 ·
Originally posted by 24boosted@Aug 26 2005, 10:46 AM
No probs, do a write up once you have it taken out so we have the info here to share with others.
[snapback]149655[/snapback]​


Yeah, for sure... I'm hoping that I don't have to take this on myself because of the potential warranty issue, but if I do the work myself I'll take pics and do a write-up.

I'm guessing that the plastic around the steering column needs to be removed to get to the gauge cluster, because there just aren't any visible screws in the cluster at all and I refuse to just pull on the face to attempt removal.

More info to follow.

In the meantime, if there are others out there that have put in custom gauges, or removed this piece, etc... your assistance would be greatly appreciated.

Thanks again!
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top