Nissan 370Z Tech Forums banner
1 - 20 of 41 Posts

·
Registered
Joined
·
450 Posts
Discussion Starter · #1 ·
This past w/e went to fill the tank in the Z, it showed 1/4 tank. At about $12.00 the gas pump clicked off, I knew this wasn't right, I got in the car turned the key to see the gas gauge and it was at 3/4 tank. I continued to fill the Z, but the gas pump clicked off at every $.11 of additional gas. I finally filled it but has this happened to anyone else? Is it common with colder temps??
I looked for a thread but could not find one.
 

·
Premium Member
Joined
·
12,469 Posts
Common issue cold or hot...the Z's gas tank is split so it's a PITA sometimes to fill all the way. Try shaking the a$$ end of the car or turning the gas filler nozzel upside down.
 

·
Registered
Joined
·
450 Posts
Discussion Starter · #3 ·
Common issue cold or hot...the Z's gas tank is split so it's a PITA sometimes to fill all the way. Try shaking the a$$ end of the car or turning the gas filler nozzel upside down.

I shook the car, no luck. I'll try the upside down adjustment at the next fillup. Thanks.
That's one problem that I would never have thought existed. :angry:
 

·
Registered
Joined
·
450 Posts
Discussion Starter · #4 ·
Common issue cold or hot...the Z's gas tank is split so it's a PITA sometimes to fill all the way. Try shaking the a$$ end of the car or turning the gas filler nozzel upside down.
Why turn the nozzle upside down??
 

·
Premium Member
Joined
·
12,469 Posts
Why turn the nozzle upside down??
I really don't know why...but this issue has been around since the car was introduced and turning the nozzel upside is an oft posted fix. It may not work everytime or at all, but it can't hurt as long as you pay very close attention to the sound of the gas filling in the tank. Having the nozzel in this position may disable the auto fuel cut-off, and we don't want gas spewing all over the paint so if you decide to try it...be prudent. Sorry I didn't post this disclaimer before.

Be aware that when your fuel low lamp goes on you still have 3+ gallons in the 20 gallon tank, maybe more depending on the shape of the measuring device/relay in the tank.
 

·
Registered
Joined
·
139 Posts
You could also try pulling the nozzle slightly farther out. Sometimes if not enough air is getting into to tank, the nozzle will shut off to avoid a build up of gas fumes.
 

·
Premium Member
Joined
·
12,469 Posts
You could also try pulling the nozzle slightly farther out. Sometimes if not enough air is getting into to tank, the nozzle will shut off to avoid a build up of gas fumes.
Good advice...vapor lock will cause the nozzel to shut down.
 

·
Registered
Joined
·
450 Posts
Discussion Starter · #9 ·
You could also try pulling the nozzle slightly farther out. Sometimes if not enough air is getting into to tank, the nozzle will shut off to avoid a build up of gas fumes.
I tried that also, it didn't work. :doh:
I've had the Z since early Spring and this is the first time I've had this problem. I did go to a different station, maybe it was their system or nozzle.
 

·
Premium Member
Joined
·
12,469 Posts
Thanks. Now it's back to the dealer, after New Years, and they get to go inside the gas tank. :doh: :shock:
Please keep us posted on how this works out.
 

·
Registered
Joined
·
281 Posts
i had this issue as well. i ended up taking it to the dealer and they replaced my gauge cluster and that was over 6 mos ago...BUT this wknd it happened again...so i don't know what to do about this
 

·
Registered
Joined
·
3,687 Posts
i guess its a cold hot weather issue, first time i hear of it, but maybe cz i have been here in hot FL for a while now.

shaking the ass of the car is a good idea

good luck

<------------------3000 posts
 

·
Registered
Joined
·
139 Posts
i guess its a cold hot weather issue, first time i hear of it, but maybe cz i have been here in hot FL for a while now.

shaking the ass of the car is a good idea

good luck

<------------------3000 posts
What if I shake my ass? Will that work? :rolf2: Oh and congrats on hitting the 3,000 mark ayman. I see how you did it too. You're as big of a thread hopper as I am. :cheers: Look I've got 30!
 

·
Registered
Joined
·
360 Posts
I have also experienced this problem, but it only occurred at 1 gas station in my town. I figured that it must have been the station's equipment. Hopefully Nissan can address the situation.
 

·
Registered
Joined
·
139 Posts
you will get there buddy

i only posted 100 more times than u did so far :thumbsup:
:finger: :jk: Only 100X, huh. Well remember, I just got my Z like a month ago. So I wasn't "qualified" to post will all you cool folks. But thanks for the support :yourock:
 
1 - 20 of 41 Posts
Top