Nissan 370Z Tech Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1
I installed my new HU and the FM reception is poor. From the reviews it's supposed to be very good, but it's worse than stock. What should I do?
It's a rat's nest behind the HU so maybe interference?
Should I look into a booster? Seems only recommended for an in-glass antenna.

I have a shorty antenna but had it on with the stock HU.
:(
 

·
Administrator
Joined
·
16,332 Posts
I have not been able to figure this out. I have installed stereos for quite some time and it always seems aftermarket HUs get worse reception than factory HUs.

This is very confusing since every other part of the HU is better than stock.

If you have a rats nest back there, that might be one cause of the problem. I would try running the wires a little cleaner and zip tie everything together.

You could try an amplified (booster) antenna, but I have never gotten good results with these.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #3
I might have to go back to the stock antenna and try that first. HU doesn't even have an amp to add noise either.
So are there inline boosters or must you go with a new antenna?
Any idea on what I could use to shield the antenna line?

It's a rat's nest mainly because of all the extra wires and extra length of them all. It's a zip tied nest
 

·
Registered
Joined
·
138 Posts
My first post here will be one that you like.

I replaced the stock radio with an Alpine 9815. My FM reception went to crap and I found the solution (actually somebody on 350zmotoring enlightened me).

The 350Z has an amplified antenna. Most shops miss this and DON'T hook the HU remote turn up to the amplifier. THe result is very poor reception. You must connect the remote turn on to the antenna and your recepetion will return to it's regularly scheduled programing!

I was very frustrate when I dropped $500 for a HU and got crap reception. I've been even more disappointed in the fact that I've read lots of people having the same problem with one particular shop doing 5 Zs and having the same complaint. If a business is installing radios and 5 cars have the same problem don't you look for the solution?

Anyway, enough of my rant on doing a job right.

Connect the blue wire from the HU to the remote turn on and you'll get the reception. Spread the word!
 

·
Registered
Joined
·
123 Posts
Discussion Starter #5
Dude, you're my hero!

Of course I think I cut that wire to save some space but I left room in case I screwed up
I'll let you know how it goes.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #7
Hooked that wire up today. My baby is back to normal. Thanks for the help.


Z-love
 

·
Premium Member
Joined
·
5,137 Posts
i was going to mention the same thing. i saw that thread also and it saved me alot of time and effort. my reception is actually alot better than it was stock.
 
1 - 8 of 8 Posts
Top