Nissan 370Z Tech Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
6,899 Posts
and you didn't invite me?

i sell you my wheels and you don't invite me? haha...just kidding man!!

where did you have this done??
 

·
Registered
Joined
·
43 Posts
Originally posted by ZEALOUZ@Sep 28 2005, 03:54 PM
What did the T-Netics ST dyno?  What mods with the turbo?
[snapback]158842[/snapback]​


it was my car. It was disappointing :(
unfortunately I had a exhaust leak and TWO intake leaks (and a crack in the MAF housing). I am getting things addressed and then I'll re-dyno.
 

·
Registered
Joined
·
191 Posts
Originally posted by 35Ounces+Sep 28 2005, 01:58 PM-->
<!--QuoteBegin-ZEALOUZ
@Sep 28 2005, 03:54 PM
What did the T-Netics ST dyno? What mods with the turbo?
[snapback]158842[/snapback]​


it was my car. It was disappointing :(
unfortunately I had a exhaust leak and TWO intake leaks (and a crack in the MAF housing). I am getting things addressed and then I'll re-dyno.
[snapback]158844[/snapback]​



i have the T-Netics too. i hope to dyno soon. hope everything works out for you! what are you hoping to dyno hp/tq once everything is right?

were the leaks a result of the the v-band clamps, bad gasket(s), bad install...etc?
 

·
Registered
Joined
·
43 Posts
Originally posted by ZEALOUZ@Sep 28 2005, 05:04 PM
i have the T-Netics too. i hope to dyno soon. hope everything works out for you! what are you hoping to dyno hp/tq once everything is right?

were the leaks a result of the the v-band clamps, bad gasket(s), bad install...etc?
[snapback]158859[/snapback]​


MAF o-ring leak (my stock MAF housing was warped at the flange???), plenum leak (custom tap), MAF housing crack (possibly from STB hitting the flange). Exhaust leak from clamp working loose after time. *missing something*

Anyhow I would like to be at [email protected] no more than 8.5psi. Then I might put a boost controller in :)
 

·
Registered
Joined
·
191 Posts
MAF o-ring leak (my stock MAF housing was warped at the flange???), plenum leak (custom tap), MAF housing crack (possibly from STB hitting the flange).  Exhaust leak from clamp working loose after time.  *missing something*

Anyhow I would like to be at [email protected] no more than 8.5psi.  Then I might put a boost controller in :)
[snapback]158864[/snapback]​



So, where was the exhaust leak? at the header to U-pipe, X-over pipe or the Y-pipe. or was it at the first clamp on down pipe or the second? just curious.

my cusco STB is being modified by a machinist friend. saw it last night. it is looking good so far. the factory strut bar is too close for me and i love my cusco so....it will go back on, one way or another! lol
 

·
Registered
Joined
·
43 Posts
I'm not sure, I didnt watch him that closely but it looked like he was near the U pipe.

I'm going to use spacers with the stock strut bar at least for now. May do a plenum spacer eventually anyhow (but I'm waiting to see if the 350evo plenum comes out this winter).

Originally posted by ZEALOUZ@Sep 29 2005, 10:29 AM
MAF o-ring leak (my stock MAF housing was warped at the flange???), plenum leak (custom tap), MAF housing crack (possibly from STB hitting the flange). Exhaust leak from clamp working loose after time. *missing something*

Anyhow I would like to be at [email protected] no more than 8.5psi. Then I might put a boost controller in :)
[snapback]158864[/snapback]​



So, where was the exhaust leak? at the header to U-pipe, X-over pipe or the Y-pipe. or was it at the first clamp on down pipe or the second? just curious.

my cusco STB is being modified by a machinist friend. saw it last night. it is looking good so far. the factory strut bar is too close for me and i love my cusco so....it will go back on, one way or another! lol
[snapback]158966[/snapback]​
 

·
Registered
Joined
·
43 Posts
Originally posted by ZEALOUZ@Sep 29 2005, 03:19 PM
35ounces:  did you notice black residue near/around your exhaust leak?  did you hear the air escaping?  just curious, i have not noticed either but doesn't mean it is not happening, even if it is just a bit.  any other evidence?  let me know.
[snapback]159075[/snapback]​



Nope. The guy at the shop started my car to move it in and immediately said, exhaust leak. He said he could hear it. I couldnt tell.
 

·
Registered
Joined
·
43 Posts
Originally posted by ZEALOUZ+Sep 29 2005, 09:34 PM-->
<!--QuoteBegin-35Ounces
@Sep 29 2005, 05:49 PM
when are you going to dyno and what year is your car?
[snapback]159117[/snapback]​


I will probably dyno the 8th of October if everything works out. i have an '04 Z with a build date of july of 2003. so that means i have an '03 ECU.
[snapback]159136[/snapback]​



hmmn I wonder if they gave you the 03 flash?
post up here if you can after you get dyno'ed...trying to determine if the flash has an effect or what.
 
1 - 19 of 19 Posts
Top