Nissan 370Z Tech Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter #1
Just figured i'd post this in case someone runs into it. if your combination meter (speedo, tach etc), the triple meter (trip computer, oil, battery) and a/c all of a sudden don't save settings when you turn off your car, and your signal indicators don't work (but turn signals are working). especially trip meter resets every time you turn off the car, check fuse 19 on the inboard fuse panel. its marked "elec parts".

i was installing a radar detector to hang off my rearview mirror, and hard wiring it to the car and accidentally shorted out that circuit out without realizing it. pulled away and the first thing i noticed was that the a/c was on. i always leave it off, then the turn signal indicators, then the trip meter. then i saw that my signals were working, just not the indicators. the trip computer was working, so i figured it was a fluke or a reset, something like that. then it happened everytime i turned the car off, and the a/c was always back on when i restarted the car.

anyway, i took me a bit of searching through wiring diagrams to figure out it was hot lead to the combination meter. figured maybe it could save someone thinking they've blown the combo meter (like i did). checked the fuse and it was blown (thank goodness that's all it was).
 

·
Registered
Joined
·
643 Posts
Another tip----always disconnect the battery when working on any electrical component.
 
1 - 2 of 2 Posts
Top