Nissan 370Z Tech Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey guys so i just got my 350z back from the shop getting dyno tuned. About 3 days and 150 miles later the SES light turned on. Went to get it checked and code PO430.They also replaced 2 coil packs that were bad. And now that im driving it it has a really bad smell along with it, like rotten eggs. I haven't noticed a difference in drivability or anything. Ive talked to a few people that said its the catalytic converter. I just wanted to make sure its the right part thats throwing the error code. Catalyst Efficiency Below Threshold (bank 2).They also replaced 2 coil packs that were bad. And now that im driving it it has a really bad smell along with it, like rotten eggs. I haven't noticed a difference in drivability or anything. Ive talked to a few people that said its the catalytic converter. I just wanted to make sure its the right part thats throwing the error code since its pretty expensive.


If it helps at all heres my mods
Tanabe exhuast
Cold air intake
550cc Injectors
Headers
 

·
Premium Member
Joined
·
5,866 Posts
Test pipes to replace the cats and see what happens. Rotten egg smell is generally bad cats I believe. And two bad coil packs immediately after tuning? That doesn't make sense either. If they were bad you should have gotten a misfire code and the car would run like crap on 4 cylinders.
 

·
Registered
Joined
·
10 Posts
best easy procedure is to disconnect your battery for 1 hour.... re-connect.... start engine and your ecu will be under air/fuel re-learning procedure..... 5 minutes to warm up engine.. no stop lights or stop signs.. you must go on open flat highway... keep rpm's at 2,000 . bring truck to 60mph and keep it at that speed for 20 minutes... exit and drive the same way on your way back...
take it easy on the gas for the next 5 days..
 

·
Premium Member
Joined
·
5,866 Posts
Two months later - any resolution OP???????
 
1 - 6 of 6 Posts
Top