Nissan 370Z Tech Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a problem that recently started with my 350Z touring roadster.

Its new, less than 6000 miles.

Whenever I turn all the way to the left or right, for instance pulling into a parking spot, there is a clicking noise and you can feel it on the peddle, as if something is shifting or loose in the front end or the steering column. If the car was front wheel drive, you would swear it was a CV joint problem, but there aren't any CV joints on the front of a rear-wheel drive car.

You can also feel it if you break hard, there is a click which you can feel in the break.

The dealership spent most of yesterday tightening every bolt on the front end, and made no difference. Now they are ordering struts..

I anyone has had a similar problem, it'd love to here from you

thanks

Paul

[email protected]
 

·
Registered
Joined
·
1 Posts
I had a simular problem with my my wifes 350 and it turned out to be the motor mount nuts were loose.Once tightened no more noise check from the bottom good luck
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
yep, that fix worked for me.

There is actually a Nissan TSB about it, but it refers to cars built prior to around March 2003, but mine was only bought April 2004 so they need to update it to cover all models!

thanks for the feedback!
 

·
Registered
Joined
·
3 Posts
I had a similar problem with my 03 Touring. There was a popping sound when you braked and when you took off while turning. The dealer fixed the problem and I was told that the upper control arm had to be re-torqued. The Service Manager said there was a notice about this problem. I don't know if he was blowing smoke but it fixed the problem. My car had 5400 miles on it at the time.

Good Luck, Hopes this helps
 
1 - 5 of 5 Posts
Top