Nissan 350Z / 370Z Tech Forums banner

Does the ALT quality really matter in a 350Z?

  • It inly matters if you really need.

    Votes: 0 0.0%
1 - 4 of 4 Posts

· Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi al, I have had my 2003 350Z for a few years and last year it began draining batteries extremely fast. replaced the alternator even though the test said the old one was fine, replaced pulley, it worked for a short while then it began draining batteries again. During this time though watching it at night unveiled the fact that at the point the wiring harness attaches to the ALT the wire was so hot it literally glowed. So a year of this going on and off where by to drive 20 miles i must have an extra full battery as it drains the 1 month old and 2 month old good battery so quick. SO ima wondering.....

Could the ALT wire need to be rerun from the ALT to the hot lead on the battery with say... 4 gauge wire?

I have heard Kraigans, Autozone... etc ... carry horribly low quality ALT's for Z's and that I should be buying a much higher end ALT... say 200+amps?!!?!? Is this true in your experience and might you have a link to a killer ALT for a great price?

Thanks again you guys!!!!

Cali
 

· Super Moderator
Joined
·
1,925 Posts
I've owned my 350Z track model for 21 years now, and never experienced that kind of a draw off the alternator. My suggestion is to backtrack all the wiring harness from the battery to the alternator and also the ground side. I suspect there's a problem somewhere in the OEM harness that's causing the problem. Nissan spec'd these components to the correct voltage and even on a 20+ year old, 110K mile vehicle they should still be adequate if not damaged.
 

· Registered
Joined
·
6 Posts
Hi al, I have had my 2003 350Z for a few years and last year it began draining batteries extremely fast. replaced the alternator even though the test said the old one was fine, replaced pulley, it worked for a short while then it began draining batteries again. During this time though watching it at night unveiled the fact that at the point the wiring harness attaches to the ALT the wire was so hot it literally glowed. So a year of this going on and off where by to drive 20 miles i must have an extra full battery as it drains the 1 month old and 2 month old good battery so quick. SO ima wondering.....

Could the ALT wire need to be rerun from the ALT to the hot lead on the battery with say... 4 gauge wire?

I have heard Kraigans, Autozone... etc ... carry horribly low quality ALT's for Z's and that I should be buying a much higher end ALT... say 200+amps?!!?!? Is this true in your experience and might you have a link to a killer ALT for a great price?

Thanks again you guys!!!!

Cali
Are you getting a dash light symbol brake and battery at the same time?
 
1 - 4 of 4 Posts
Top