Nissan 370Z Tech Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys I'm running greddy 18g tts with the HKS FCON. I recently had a boost leak from a burnt coupling, after changing it I've had several other boost problems fixed. I've smoke tested and fixed several vacuum leaks by adding a manifold box off of the brake booster/intake. I then found a leak in one of my kinetix manifold runners. I replaced with my old stock adapted manifold.

I now have no detected leaks, but instead of boost surging which it was doing after fixing the first leak (boosting to like 25 psi when set to 15, and barely boosting still) now it is in almost a limp mode, where when I floor it while idling it will just bounce between 2-2.5k Rpm. It barely stays running, I don't believe its leak/mechanical.

Could it be an ecu issue, or something related to the addition of the manifold box/bad vacuum routing? Anyone had any problems like this?

Seems like when I hit bumps it also causes it to stall... Car was running just fine before I got the one coupling leak.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Well turns out part of it were those aftermarket dumb led tail lights. So no more limp mode. I was stupid for installing them. However, my wastegates are acting up and not boosting all the way all the time and sometimes I get no boost. I have no leaks.. But sometimes cruise control doesn't work so I wonder if it's sensor/computer related..

Also I rerouted vacuum lines to a manifold box, Im pretty sure that's the issue now but I can't find the proper vacuum routing for the greddy kit anywhere. The ones on their website barely shows anything.
 
1 - 3 of 3 Posts
Top