Nissan 370Z Tech Forums banner
1 - 20 of 27 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
hello
I own a 03z trackpack with a vortech v2

I can be in any gear , under boost or not . my car cuts at 5000-5200rpm .
it dont spudder or nothing it just wont go past .

Im 100% sure its not the MAF or fuel cut .

oddly enuf some times ill take it out and car will rev fine, and 85% of the time it buggers up

could this be the TCS or some thing messing up ?

if so how would i find out and wheres the sencor ?

thanks from the new guy ..
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #2 ·
UPDATE:

wll i see no one has any ideas ... dont feel bad cause i took the car in to Nissan and they took it for a drive and they did not get a error code from the ecu of any type ..
as well they tested the emissions and it was 100% perfect.
and they checked the rev limit and its set at 6700.

they could find nothing wrong with it at all ..
so the car came home unfixed and left every one puzzled ..
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #4 ·
i would but i really do not know of any shops around here that deal in this stuff .
Nissan was my best bet . the readings and stuff they took of my car they are having them sent off to be looked at further.

does any one know of any places in souther Ont that i could take it to ?

thanx any help is great
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #7 ·
i had just a local shop to do it ...
but they dont have the stuff to service it or any thing .

nissan had said that if it was the FMU that they woulda still cought a error code or some thing
 

·
Premium Member
Joined
·
6,474 Posts
i had just a local shop to do it ...
but they dont have the stuff to service it or any thing .

nissan had said that if it was the FMU that they woulda still cought a error code or some thing

That's cool. But did they install it correctly? Did this start right after the install? anything happen to cause this?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #12 ·
well i called Nissan and to start im goign to get the ECU flashed .. for 40$

yes the vortech was installed rite .. its been in the for little over a year now with no problems at all.

I live in Brantford Ont about 30 min south of Toronto..

yes it could very well be the FMU but vortech told me that the FMU and stuff would not effect the rpms at all ..
Nissan had spoke with vortech and no one has answers at all ..

car boosts 8psi 100% and goes like snot then stops at 5000 then creeps to 5200rpm ...

works perfect some times then other times its messed ..
like it could act up then i pull in for gas and leave and its fine ...

thanks for the help guys
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #13 ·
well got the car back today from getting flashed with the 06 version ..

now it goes past 5000rpm and does it 6000 rpm lol
the dealer ship said that its nothing with the vortech , but they had tested it all any ways .
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #16 ·
got perfect fuel pressure ..
im running 2 pumps the stock in take and a 175lph inline .
its not leaning out at all ..

i called vortech today and they told me to check all the wires and i had done this but that was a lost cause .

car will hit 5500now and jaust stop like its hitting redline and holds boost 8psi ..

now if i leaned out the car would at least sputter or the rpms would drop to try and recover , but it keeps on trying to rev like redline .

only other thing i can think of would be the spark box for the vortech ..
but the plugs look perfect nice glaze on them , not white or dark ..

my self and nissan are 100% puzzled and vortech cant come up with any ideas ..

have checked ( FMU , flashed ECU with a 06 version , plugs , fuel system and pressure , wireing , TCS )

not like i rev the car out to 5k any ways on a daily basis lol ...
 

·
Registered
Joined
·
24 Posts
I know some systems have Torque management built in. Which will cause a similar problem when the limits are probed. I am not sure if nissan has TQ management in their ecu's but if they do then it should have been removed when it was reflashed. it may be a direction to look.
 

·
Registered
Joined
·
3,687 Posts
well glad to see that it was all done
u could have reflashed ur ECU urself for free!!!
its so easy
im surprised that no one on the forum told u that.
i wish i have seen ur post before, i could have told u about it
 

·
Premium Member
Joined
·
6,474 Posts
well glad to see that it was all done
u could have reflashed ur ECU urself for free!!!
its so easy
im surprised that no one on the forum told u that.
i wish i have seen ur post before, i could have told u about it

You cannot reflash for free. It requires the ability to write to the ROM.

You can however Reset the ECU. But this is NOT the same thing.
 
1 - 20 of 27 Posts
Top