Nissan 370Z Tech Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey I'm new to this forum but i'm hoping I can get some help/direction. I recently got my 2011 nismo and my last Z never had this issue, At idle my Air conditioning blows very cold and its great, as soon as I drive it around town maybe two miles it blows hot air. I checked my climate control and its still plugged in. I had a shop look at it they checked for leaks and recharged the system to 1.11 and at idle its cold but when you drive it is hot. Please leave any information you guys might have id really appreciate it.
 

·
Super Moderator
Joined
·
1,584 Posts
That's not a known issue with either the Z33 or Z34. Sorry to say, but I'd pay the diagnostic fee at a Nissan dealer (usually an hour of shop time) to have a trained Nissan tech figure it out. It's cheaper than throwing parts at it.
 

·
Registered
Joined
·
50 Posts
I would guess (without hands on), the thermal switch is either faulty (not unusual) or it's doing it's job well and cutting off the compressor because the refrigerant is not cooling properly in the condenser (low level due to leak) or other issue in the system where the refrigerant isn't making it through the condenser (like a faulty compressor). Did the shop do a dye test looking for leaks or just a visual of the components? I agree with dkmura in that you need to have an AC pro/dealer check this out. And..... Now would be a good time because you allegedly have a "full load" of refrigerant (baseline to compare current readings) and if they are low, a dye test (if not done originally) will reveal the component which is leaking.
 
  • Like
Reactions: dkmura
1 - 3 of 3 Posts
Top