Nissan 370Z Tech Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi I have a 350z nissan 2004 automatic transmission. with codes p1716 Revolution Sensor P1754 Imput Clutch, I lost my reverse early morning, the when it warms up it engaged. it kicks from from 1st gear to 4th gear, some time it slips fronm 2nd to 3rd and 4th. 3 day ago I just replace 5 qrtz of transmission fluid and it is working somehow better than before. Last year a technitian welded a solenoid contact in the TCM. Everybody tell me that I have to get another transmission. I can get an use one with low mileage but I have a tcm to replace the one that is working now. Any idea if I replace the TCM it will work or just get another tranny? Than you
I started having issues with not shifting properly so I took my 2005 Roadster to the nearest shop and they diagnosed that I needed a new transmission (approx $4k)! It was throwing P1759, P1757, and P0744 codes. So I spoke to my brother about it (He's an ASE certified mechanic and owns a shop), he decided to break it down and have a look. After much diagnoses, research and internet diving we were able to find the problem part and fix the issue for $25. Incredible! Issues are gone! He's writing up instructions for the fix now and can provide them for a fee. I know this forum is all about sharing info but this is his profession. PM me if you are interested. I helped him do the work so I can tell you that while it is a pain, its relatively easy considering the savings.


Ok Thank you
[/QUOTE]
 

·
Super Moderator
Joined
·
1,373 Posts
Since nobody else is responding, let me take a shot. Yes, try replacing the TCM before you start replacing the slushbox. It's also notable that when you added ATF to the tranny that it began shifting better. When was the last time the tranny fluid was changed? Also, how many total miles are on your Z, and when did you come to own it?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Thank you, It was 75k now is 111k, about when was the last time that the fluid was change, I don't Know.
 

·
Super Moderator
Joined
·
1,373 Posts
Keep in mind that your Z33 auto tranny has almost 11 quarts of matic J ATF in it. If you have no idea when the tranny fluid was last changed, you need a tranny flush with new fluid ASAP. I recommend Redline D4 ATF as a good synthetic replacement.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
dk Just 4 days ago I drain 5 quartz a add valvoline synthetic I have 8 qrtz of Redline D4 ATF to use. But some people said that I should not flush and replace all ATF. Should I ? Thank you. All your advises ae welcome.
 

·
Super Moderator
Joined
·
1,373 Posts
I've heard both sides of the high-mileage tranny fluid changes and remain of the opinion that fresh fluids/lubricants are the better way to go. Does your dipstick indicate your tranny fluid is at full? If so, I'd install your TCM and see how the powertrain works.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Ok I'll go ahead, take of the valve body, teste each solenoid ohms try clean valve body and then reinstall and see if that works. Thanks.dk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Hey dk I found this morning something new. I used to get 2 codes, P1716 and P1754, now afret replace 5 qrtz of atf, the P1754 Imput clutch disappears. Now it only read 1716 Revolution Speed sensor.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
No yet. I need some time to work with it. So I don't know much about this, but how come that sensor fails.
 

·
Registered
Joined
·
16 Posts
I'm not an expert, but I can advise you on another portal where they discuss problems with cars. I found several discussions here . Top starters have had similar driveline problems and, with the help of other car enthusiasts, have found a solution to these problems. Perhaps their posts will help you find the cause or you will find new ideas on what you may have a problem and how to fix it.
 
1 - 13 of 13 Posts
Top