Nissan 370Z Tech Forums banner

181 - 185 of 185 Posts

·
Super Moderator
Joined
·
1,574 Posts
Discussion Starter · #181 ·
The first race report for 2021 has to do with the preparations for the race season. Yesterday was the first test of our repairs to the ECM failures of last season. Over the winter, the entire main harness for the HR was pulled, checked and repinned. There were some sections from the drive-by-wire throttle pedal to the ECM that were found to be slightly damaged and possibly causing intermittent shorts in that section of the harness. These sections were repaired/replaced and properly soldered in position and the entire wire bundle placed in a wire harness to protect it.

Obtaining a new 23710-EV12C ECM was not easy or cheap, but was loaded with a stock tune and ready to go. After plugging everything in, we crossed our fingers and turned the key. The HR started right up and ! had full throttle control. The next step was to get a fresh tune on it, and I'd been able to procure an appointment for today to get that done. All in all, we should have had this Z ready for battle exactly one week before we'd pack up for our opening race.

Unfortunately, that's not what happened. After getting the trailer hitch on, the trailer loaded and the Titan backed up, I found the HR would no longer idle smoothly and worst of all, had almost NO throttle response! Crap- we're dead in the water...AGAIN.
 

·
Super Moderator
Joined
·
1,574 Posts
Discussion Starter · #182 ·
The first race weekend is here and I won't make it. While there's still hope for the T3 Z, I simply cannot commit a FOURTH ECM to the effort until we develop a new hypothesis about what is causing all these failures. We're going to take Rob Fuller's (of Z Car Garage fame) advice and see whether it's a problem with reprogramming and matching the throttle bodies to the new ECM, but since the shop is on the other side of town, it'll have to wait until after the weekend.

I'm headed to LaJunta anyway, as dual roles of a tech worker and Colorado Region SCCA official. If the Z were running, I'd also be a driving instructor for the driving school that starts today. But I'm wearing enough "hats" this weekend, and after conferring with the chief instructor, decided to concentrate on the other duties for the weekend. With the loss of this weekend, it'll be difficult to defend my Rocky Mountain Divisional T3 title from last year, but that's reality.

The other project I'm working on closer to home is the resurrection of the GT3 Z project. This tubeframe car is quite different than the T3-spec Z33 (although it looks like one) and one of my good friends has been working to complete some major aero mods and maintenance/repairs to get it closer to a runner again. Who knows? Maybe I can get a few shots of it when I return next week.
 

·
Super Moderator
Joined
·
1,574 Posts
Discussion Starter · #183 ·
ECM problems on my T3 Z have nixed the first two races on my 2021 schedule. While we managed to resurrect the third 23710-EV12c and get it to run, there's not enough time to do any test or tuning before the race in Topeka. I'm unwilling to trust that everything will be OK before towing the 500 miles to HPT for the SCCA Majors this weekend. Call me timid, but once bitten, twice shy.
 

·
Super Moderator
Joined
·
1,574 Posts
Discussion Starter · #184 ·
The 2021 season has been one of the most frustrating in my 33-year racing career. After tuning my Z33 on the dyno, we took i t to Pueblo Motorsports Park (PMP) for testing only to have it exhibit some bizarre brake problems (LF locking on out lap) before having limp mode kick in down the front straightaway! Checked traffic before pulling to the inside and waiting to be towed in. We tried scanning for codes and found the same P0603 code as before. That one indicates "Internal control module keep alive memory module (KAM) error". WTH?

Erased that code and while it didn't return, I found P2138 kept coming back in the ECM section, as did the ABS code C1131. Both codes indicate a problem with the ECM properly functioning, but this is the second new 23719-EV12c ECM after the original EV12a unit failed. Is it possible my Z is EATING these components like sushi at the buffet table?

At this point, I haven't even got a good hypothesis to go on. Perhaps there's some interaction between ABS and ECM systems that's degrading the ability to open the TBs and triggering limp mode? It's a frustrating mystery while the SCCA race season slips away. I'm already too far behind a Porsche driver to contend for another Divisional championship and the Mid-America Majors title is also beyond reach. Still hoping to qualify for the Indy Runoffs, but that's slowly slipping away if I can't get this figured out pronto!
 

·
Super Moderator
Joined
·
1,574 Posts
Discussion Starter · #185 ·
After spending the past week tearing the T3 Z down, it's been a fruitless search. While the P2138 doesn't appear to be a hard code, it activates the moment the throttle is touched. Checks of the battery, alternator, grounds and other electrical components have shown they are intact and functioning within normal limits. Currently checking through the IPDM and while the fuses are all intact, I'm still trying to understand the relays better. Also pulling the front wheel speed sensors to determine if the ABS code C1131 is from them. Lots of work- few results so far.
 
181 - 185 of 185 Posts
Top