Nissan 370Z Tech Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey all,

so first off, I did research this problem but I cannot seem to find a solid answer.

ive had this 2004 that was my quarantine project, I’ve been rebuilding it. Finally took it out for a drive the other day and had fun getting on the hwy.

Maybe too much fun...when I went to 2nd tcs kicked on and the car lurched for a second since the tires slipped. That isn’t the problem.

My airbag light is now blinking...joy 😂

I’m thinking something got knocked loose in the commotion
 

·
Super Moderator
Joined
·
1,541 Posts
The front airbag sensor is located under the hood latch. You'll need to bend down near the radiator to see the sensor. But the "commotion" may be unrelated, so be sure to check the airbag sensors under the seats, and maybe pull codes to see if the diagnostic system can identify where the loose connection is. Since this is a rebuild, were the airbags blown when you bought this Z?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
The front airbag sensor is located under the hood latch. You'll need to bend down near the radiator to see the sensor. But the "commotion" may be unrelated, so be sure to check the airbag sensors under the seats, and maybe pull codes to see if the diagnostic system can identify where the loose connection is. Since this is a rebuild, were the airbags blown when you bought this Z?
No they were no. I do have side impact ones..and I’ve redone the seats. I pulled codes but literally nothing. Just this blinking airbag light.
I’ll try taking the seats out tomo to check the connections
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4 (Edited)
No they were no. I do have side impact ones..and I’ve redone the seats. I pulled codes but literally nothing. Just this blinking airbag light.
I’ll try taking the seats out tomo to check the connections
I just checked and theee aren’t any codes.
I’m using up rev to read the codes since I don’t have a scanner atm.
Also the crash sensor is connected. I office in my garage, and this sits next to me atm. It doesn’t have a bumper right now and the crash sensor is connected.
By chance does anyone have thoughts to what it could be?

also the car was never wrecked. Just neglected in the desert for 20 years
 

·
Super Moderator
Joined
·
1,541 Posts
I just checked and theee aren’t any codes.
I’m using up rev to read the codes since I don’t have a scanner atm.
Also the crash sensor is connected. I office in my garage, and this sits next to me atm. It doesn’t have a bumper right now and the crash sensor is connected.
By chance does anyone have thoughts to what it could be?
Are you using UpRev Cipher to read the codes? It may not show in the ECM section, so be sure to check BCM codes. I bet a skilled Nissan tech with a CONSULT III unit could figure it out quickly. Might be worth paying for an hour of shop time (the usual charge) to have the diagnostic done.

The other thing to check would be the actual connections for the steering wheel, PS and side impact airbags.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Thanks for sharing knowledge of what can cause the light to appear.

I haven’t pulled seats. But I think it’s the next step
 
1 - 6 of 6 Posts
Top