Nissan 370Z Tech Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
My 350z has the CEL and codes 1122 1126

I have done quite a bit of reading on these faults but I still cant seem to find the problem
so far I have changed the throttle body (no change)
I tried changing the relays in the IPDM and no change
then I tried another IPDM and still no change
I checked continuity of the wire harness with the ECM and couldnt find anything wrong
wiring harness looks ok... the Throttle body motor clicks on when you turn on the ignition and the vehicle will start

I am at a loss of what else this could be

any ideas?
 

·
Super Moderator
Joined
·
1,557 Posts
Problems like this don't just crop up at random. Provide us with a more complete history (year, mileage, mods and whether you installed them) and whether these codes are throwing you into limp mode or just throwing a CEL up. Also, have you had a pro tech in your area on the case yet?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Problems like this don't just crop up at random. Provide us with a more complete history (year, mileage, mods and whether you installed them) and whether these codes are throwing you into limp mode or just throwing a CEL up. Also, have you had a pro tech in your area on the case yet?
Its a 2005 350Z convertible no mods...its stock with 41,000 miles.... its in limp mode . wont go over 1500 rpm..... I have not had anyone look at it yet.... I have unplugged the gas pedal module and plugged it back in but no difference.... I am wondering if it could still be the IDPM I bought a used one from ebay and it still has the same codes when I swapped it but who knows, maybe it is defective too
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Why did you replace the IPDM? How long has the car been in limp mode?

I replaced the IPDM because 1126 indicated a bad throttle control relay.... I tried just changing the relay but didn't make any difference so I tried another IPDM but no change.... The car started going into limp mode in the Middle of August and I kept clearing the codes and continuing driving it.. finally the codes come back now immediately and car will not get out of limp mode.
 

·
Super Moderator
Joined
·
1,557 Posts
My advice is to get a Z33-trained Nissan tech with a CONSULT III unit to diagnose this problem. Don't waste anymore time trying to DIY this yourself- a trained tech with a diagnostic tree is needed.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
My advice is to get a Z33-trained Nissan tech with a CONSULT III unit to diagnose this problem. Don't waste anymore time trying to DIY this yourself- a trained tech with a diagnostic tree is needed.
\

I think that would be the best thing as well... I cant think of anything else that I can do

thanks for the advice

Cheers


JJ
 
1 - 8 of 8 Posts
Top