EBC Red Stuff - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 4 (permalink) Old 03-23-2006, 01:07 PM Thread Starter
 
Join Date: Mar 2006
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Hey all. I am new to the Z, I just bought it 3 weeks ago. I bought an 03' Touring and replaced the front pads and rotors last week. I didn't want to spend the money yet to upgrade the barking system because there are a few other things I would like to do first. So anyways I replaced the rotors with OEM rotors form Nissan and bought some EBC Red Stuff pads on ebay. I know break in period for new pads and rotors are about 100 miles or so to let the pad and rotors settle nicely but at about 95 miles they are starting to squeak a little bit. It's not too much but I was curious if after the break in period they will stop squeaking. Can anyone with EBC red stuff pads and stock rotors enlighten me. Thanks for the help. Oh by the way I searched this and only came up with pinned everything you need to know about brakes thread and it did not answer my question.
pikespeakz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-23-2006, 08:49 PM
 
Join Date: Oct 2004
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I added EBC Greenstuff .....fronts are fine but the rears make noise. I emailed them and they told me that the noise would disapate ~ 300 miles. I hope that they are correct or this will be my last purchase from them.
311s is offline  
post #3 of 4 (permalink) Old 03-23-2006, 10:27 PM
Grand Touring Member
 
westpak's Avatar
 
Join Date: Feb 2004
Location: Lake Worth, FL
Posts: 2,063
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
The Reds are Autox/light track pads and a little harder than the Greens so you will get a little bit of squeal, I get it some times but not much.

03 350Z 554RWHP
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- 90 300ZX TT



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
westpak is offline  
 
post #4 of 4 (permalink) Old 03-24-2006, 01:03 PM Thread Starter
 
Join Date: Mar 2006
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks guys, I figured after they break in it would go away. It seemed to start right after the coating wore off. Like I said it's not bad but with a nice car the worse thing is pulling up to a light sounding like you need a brake job when they were just done. Anyways thanks again.
pikespeakz is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome