05 with Momentum single turbo runs rough - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 2 (permalink) Old 05-06-2017, 05:52 PM Thread Starter
Base Member
 
Join Date: Jun 2011
Location: pouce coupe
Posts: 47
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
05 with Momentum single turbo runs rough

I had the car at a dyno shop in Spruce Grove. They installed the turbo and dyno tuned it. I went to pick it up and it acted like it was missing until you floor it then it turned on. He added timing and adjusted MAF and then it seemed fine. I trailered it home and ran it 2 months later and same issue. The shop is 6 hours away so I want to try and figure it out. It acts rich . Any ideas guys ?
HANDSOME is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-06-2017, 07:25 PM
Grand Touring Member
 
dkmura's Avatar
 
Join Date: Feb 2004
Posts: 1,059
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 103 Post(s)
How many miles on your Z and did you build the short block before the turbo install?
dkmura is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome