[HOW TO] Clutch and Flywheel Install - Page 2 - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 1Likes
Reply
 
LinkBack Thread Tools Search this Thread
post #11 of 12 (permalink) Old 03-18-2015, 04:51 PM
Junior Member
 
Join Date: Feb 2015
Location: Texas
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
My boyfriend and I followed the instruction, also changed master, slave cylinder and installed stainless steel clutch line, once we finished we tested the car. I noticed right away my power steering isn't working but we checked and it's full. Does anyone know what could of caused this? I was thinking of bleeding the system.
zdriftergrl is offline  
Sponsored Links
Advertisement
 
post #12 of 12 (permalink) Old 03-18-2015, 09:55 PM
Grand Touring Member
 
3point5's Avatar
 
Join Date: Sep 2008
Location: the 303
Posts: 1,618
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by zdriftergrl View Post
My boyfriend and I followed the instruction, also changed master, slave cylinder and installed stainless steel clutch line, once we finished we tested the car. I noticed right away my power steering isn't working but we checked and it's full. Does anyone know what could of caused this? I was thinking of bleeding the system.
Did the metal tubes that connect the pump and the rack get damaged when you removed the transmission?

'03 Z33
'71 S30
'04 Triton 5.4
3point5 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome