What would make a car do this? - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 5 (permalink) Old 04-17-2019, 03:06 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
The vehicle idles bad but when the fan for the a/c and heat is on it idles solid, but when it gets warm and the fan isnt on it idles bad then dies and wont start back up until it cools down. No codes are being thrown
ssandersz is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-17-2019, 04:03 PM
Grand Touring Member
 
dkmura's Avatar
 
Join Date: Feb 2004
Posts: 1,076
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
The last time I responded to one of your queries, there was no response. Can you provide some basic information on your Z? Like how many miles are on the odo? Any mods or significant repairs that can affect the idle? I'm willing to help, but wild guesses are not very helpful...
dkmura is offline  
post #3 of 5 (permalink) Old 04-17-2019, 07:52 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Sorry, i was still figuring out this website wasnt sure how to reply, theres 150k miles on it. Theres a raised intake mod and cold air intake but that was on the car before i bought it a couple years ago. I havent done anything that should effect the idle so thats why im unsure of the source of the problem
ssandersz is offline  
 
post #4 of 5 (permalink) Old 04-19-2019, 08:13 PM
Grand Touring Member
 
dkmura's Avatar
 
Join Date: Feb 2004
Posts: 1,076
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)
Have you recently done a scan of the ECM to determine if any codes are held in memory? At 150K, it could be any number of things, but I suspect there's a code or two that could help narrow it down.
dkmura is offline  
post #5 of 5 (permalink) Old 04-24-2019, 12:58 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Well my reader wouldnt connect at all when it was throwing codes so i took it to Nissan to let them scan it and i changed everything that was a redflag (cam and crank senors and new bettery) but it hasnt thrown anymore codes since those changes which confuses me. Because before i changed them it had the same symptoms except now its dying and not starting back up until it cools off but no check engine light or anything. It runs great except at idle but with the fan to the a/c and heat on it idles solid.
ssandersz is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome