Loud Clunk when braking - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 2 (permalink) Old 01-15-2019, 04:23 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Loud Clunk when braking

2005 350z Touring

I recently changed the front forward lower ball joint and lower control arm as well as the tie rod end (all stock).* With everything reinstalled and torqued, I get a LOUD clunk when I apply the brakes, even at very low speed (driveway).* This occurs when moving forward but not when moving backward.* I checked the calipers and brake pads.* There is no play in the wheel in any direction.* Nothing seems loose.* This problem wasn't there before.* Any ideas?* I've searched the forums and internet but haven't found an answer.
Harbison is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-17-2019, 03:51 PM
Grand Touring Member
 
dkmura's Avatar
 
Join Date: Feb 2004
Posts: 1,047
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 100 Post(s)
You posted this on the "other" Z33 board and I doubt you'll get any different answers here. Since this was a before and after situation with your repair, there's undoubtedly some problem with reassembly. I'd have another experienced tech go over your car, as there's not much any of us can do while staring at a keyboard and a loosely written description.
dkmura is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome