high rev - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 2 (permalink) Old 10-03-2016, 02:31 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
high rev

Hello to all. Recently I changed my tranny fluid as well as my rear end fluid. Every since then I cannot accelerate fast because the car rev's high for a moment before it comes back down and catches. So when I get on the highway I start out a bit slower. I replaced the fluids with Redline products. Its an 05 350Z 6 spd. with 108,000 mostly softly driven miles on her. I dont drive her hard 90% of the time. Any help would be greatly appreciated - Matt
maddhatter is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-06-2016, 10:51 PM
Touring Member
 
dkmura's Avatar
 
Join Date: Feb 2004
Posts: 637
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 48 Post(s)
Welcome- your problem sounds more like a worn clutch than anything related to your tranny and diff fluid change. BTW- what kind of Redline products did you use in either of those applications?
dkmura is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome