No tach and temp signal. and rad fans always on - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 1 (permalink) Old 08-29-2016, 05:07 PM Thread Starter
Base Member
 
Join Date: Apr 2016
Location: BC Canada
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
No tach and temp signal. and rad fans always on

So my car has had some bad luck this summer. It seems that corrosion in my engine bay fuse box had contributed to my haltechs demise. So the haltechs repaired and back in and the cars running fine. Except for this new problem where i have no tach or coolant signal on my gauge cluster. Also the gauge clusters digital odometer isnt responding to input from my side buttons for my info/trip a b ect. and aswell my fans kick on as soon as i put the key to "on"
its an 03 mt touring
I can see coolant temp and rpm signal within the laptop when connected to the ecm.

So far I have:
checked and replaced all the fuses
swapped out the ipdm (engine bay fuse box) swapped some ac relays on it
pulled my drivers side kick panel fuse box right out took it apart and cleaned and inspected it , pinched the fuse connections tight so i know im getting good contact there.
checked out the connections on the unified ac amp meter behind the stereo
dropped the steering column and checked the connections on the back of the cluster all seem good

i think this unified ac amp meter is suspect as once it was unplugged and my fans kicked on in a similar way.

any ideas?

Thanks

2003 Pearl 350z , Greddy 20g TT kit, greddy dual exhaust, Haltech, turbosmart bov, TB vortex spacer, 1/2" intake mani spacer, 6061 underdrive kit, AEm water meth, fatty oil cooler,PS cooler, Cutstom grill and aero, slammed on coils with full kinetix suspension package, 18x10 square setup , arp wheel studs, some gauges that are blue because racecar, 460ish hp 370Tq on 4.5 psi
toneloke28 is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Replace with
For the best viewing experience please update your browser to Google Chrome