Just purchased 350z. Cranking problems ? - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 
LinkBack Thread Tools Search this Thread
post #1 of 2 (permalink) Old 06-14-2016, 06:20 PM Thread Starter
Junior Member
 
Join Date: Jun 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Just purchased 350z. Cranking problems ?

Just purchased a 2004 350z with 120k less then a week ago from I guess you could say a sketchy car dealer. Test drove car and everything was great. guy told me it had a belt squeak the first start of everyday so that would need to get checked but that's it. First day car sat in my driveway but started it up multiple times fine. Second day drove it to my friends house. On the way to his house engine , slip and traction lights came on. Car stalled out and wouldn't turn over for a few minutes. Car would stall out every 3-5 mins of driving until i finally made it back to the safety of my driveway. Fortunately there's an autozone on the way home so I stopped and they were able to read the codes . It's throwing p0335 crankshaft position sensor and p1444 purge volume control valve. Been researching and they seem like easy reasonably cheap fixes and I have a schedule set with my mechanic for tm morning. However, I myself checked the crankshaft sensor on the drivers side and it doesn't even appear to be connected to a harness??? If I'm looking at the right thing ??(I believe it to be that green and black thing) How is that possible ? I'm posting pics below but it appears to not be connected to any harnesses . Where is the wire harness supposed to be ?? Could it have been detached ? Can it be replaced ? Is it expensive ? Could it be floating around underneath the engine somewhere ?HELP
Attached Thumbnails
Click image for larger version

Name:	image_1465942668142.jpg
Views:	78
Size:	114.3 KB
ID:	50754   Click image for larger version

Name:	image_1465942719830.jpg
Views:	79
Size:	103.0 KB
ID:	50762   Click image for larger version

Name:	image_1465942832739.jpg
Views:	80
Size:	123.9 KB
ID:	50770  
Cjrswish is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-15-2016, 04:45 PM
Touring Member
 
dkmura's Avatar
 
Join Date: Feb 2004
Posts: 585
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Welcome- since you just purchased this Z, why not take it back to the sketchy dealer and ask them for some help in repairing it? You really need a tech who has training with a VQ35DE to determine what's wrong.
dkmura is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
Replace with
For the best viewing experience please update your browser to Google Chrome