cam position sensor - Nissan 350Z Forum, Nissan 370Z Tech Forums
User Tag List

 
LinkBack Thread Tools Search this Thread
#1 (permalink) Old 06-18-2010, 10:52 AM
Base Member
 
asianmami021883's Avatar
 
Join Date: Dec 2008
Location: Los Angeles, CA
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
cam position sensor

hey all. i was trying to change my cam sesors bank 2 and 1. however im having a little problem locating them i see a green connector on the passengerside. by the fire wall and there is a grey connector on the intake side under the back of the manifold can some one pls let me know where is the specific location.. i have the sensors in hand brand new ready to install picturs would also be helpful thanks...
asianmami021883 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-18-2010, 11:22 AM
Grand Touring Member
 
westpak's Avatar
 
Join Date: Feb 2004
Location: Lake Worth, FL
Posts: 2,063
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
those two plugs are it
westpak is offline  
#3 (permalink) Old 06-18-2010, 12:49 PM
Grand Touring Member
 
PerfZ's Avatar
 
Join Date: Sep 2004
Location: Columbus OH
Posts: 5,853
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
It can be a little tricky getting those plugs off. IIRC, you need to push in on the tab, pushing towards the engine, not down on it. Other than that, pretty easy although somewhat limited clearance on the drivers side. Question - why are you replacing both? Did they throw a SES light and it says both were bad? Just curious.

Hotchkis Z1 Motorsports JWT Hawk SSR Crawford
ZeeToyz Valentine Sumitomo Royal Purple Zaino



I like my 350 but I love my 300ZX TT more. Sorry babe.....
PerfZ is offline  
#4 (permalink) Old 06-19-2010, 01:40 AM
Base Member
 
asianmami021883's Avatar
 
Join Date: Dec 2008
Location: Los Angeles, CA
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Thumbs up cam position sensor..

yeah i was driving about 45mph ans the car suddenly cut off. then i had to restart which was crazy cause it was as if i stalled and i know i didnt but. i had took it to auto zone and used the obd to search for codes and boom imy assumption on the sensor was correct both banks are throwing codes p0340. which is the cam sensors them self i have the parts already and i was planning on taking them out in the morning.. but i am so thanks ful for everyones feed back to this situation. also i will be replacing the crank sensor aswell as i remeber they all work together cams and crank sensor. im a little low on funds right now so i will get that done next pay period. but for now i just got the sensor in the mail angled driver side and dtriaght passenger side. correct me if im wrong but those two are ready to go.. thanks again...
asianmami021883 is offline  
#5 (permalink) Old 06-20-2010, 02:22 AM
Base Member
 
asianmami021883's Avatar
 
Join Date: Dec 2008
Location: Los Angeles, CA
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
cam position sensor..

job well done.. thanks you guys... i've completed the installment.. will post pics..
asianmami021883 is offline  
#6 (permalink) Old 07-16-2010, 12:45 AM
Junior Member
 
Join Date: Jul 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by asianmami021883 View Post
yeah i was driving about 45mph ans the car suddenly cut off. then i had to restart which was crazy cause it was as if i stalled and i know i didnt but. i had took it to auto zone and used the obd to search for codes and boom imy assumption on the sensor was correct both banks are throwing codes p0340. which is the cam sensors them self i have the parts already and i was planning on taking them out in the morning.. but i am so thanks ful for everyones feed back to this situation. also i will be replacing the crank sensor aswell as i remeber they all work together cams and crank sensor. im a little low on funds right now so i will get that done next pay period. but for now i just got the sensor in the mail angled driver side and dtriaght passenger side. correct me if im wrong but those two are ready to go.. thanks again...

my sensor failed today but I am still able to start it up and drive..

I am glad I found threads like this on google...
one dealer is trying to get $700..

can you please post your photos, also, was it hard to reach the sensor?

btw, will the service lights go away after you replace the sensor?
dealersuck is offline  
#7 (permalink) Old 07-16-2010, 09:06 AM
Grand Touring Member
 
westpak's Avatar
 
Join Date: Feb 2004
Location: Lake Worth, FL
Posts: 2,063
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
eventually they would go away if the incident doesn't keep occurring but I would just go by an autozone or similar and have them clear the lights
westpak is offline  
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome