Nissan 350Z Forum, Nissan 370Z Tech Forums - View Single Post - Did I Buy Someone Else's Problem?
View Single Post
post #3 of (permalink) Old 03-18-2016, 09:38 PM
Znisie
Junior Member
 
Join Date: Mar 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had the same problem temporarily with my '04 350Z (Roadster Touring 6 speed manual transmission). Once I parked on a flat surface, turned the car off and restarted the car the lights all went off. My TCS will occasionally engage if I hit a slick spot on the road or simply park on an uneven hill. I may be completely wrong but while it certainly can be an indication of something wrong and worth a diagnostic, for all intents and purposes the TCS system is just automatically disabled and shouldn't (?) affect overall performance. Check that the TCS switch is on. Tire size other than the recommended sizes can also cause the TCS to disable & indicator lights to come on. Screen shots from my owners manual pages attached explain it a better than I can. The service engine light comes on when it's time for a servicing. Mine comes on, stays on for a while and then turns off, I suspect it will stop coming on once I get my regular servicing done.
Attached Thumbnails
Click image for larger version

Name:	TCS.JPG
Views:	67
Size:	119.2 KB
ID:	50561   Click image for larger version

Name:	TCS2.JPG
Views:	64
Size:	118.5 KB
ID:	50569  
Znisie is offline  
 
 
For the best viewing experience please update your browser to Google Chrome